Faites Du Jeu
Vous bénéficiez d'un accès restreint . Certaines rubriques (Discussions générales , méthodes et pronostics Loto , Euromillion et Keno ) sont cachées ou inaccessibles aux invités .

Les inscriptions sur le forum sont ouvertes Enregistrez vous en remplissant le formulaire

Voulez vous développer vous même vos propres codes ?

Poster un nouveau sujet   Répondre au sujet

Voir le sujet précédent Voir le sujet suivant Aller en bas

Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Ven 15 Déc - 13:28

Bonjour,

Envie de programmer ,  de faire vos modules de calculs, mais vous ne savez pas comment ?

je vous invite à faire un clic sur ce lien [Vous devez être inscrit et connecté pour voir ce lien]
 [Vous devez être inscrit et connecté pour voir ce lien]
vous allez télécharger maprogrammation.zip
De ce zip avec winzip ou autre vous allez pouvoir extraire son contenu dans un répertoire de votre choix sur votre machine

- RunTimeWindev.exe   
Ce programme sert à lancer des programmes que l'on peut ouvrir ou modifier avec le bloc Note ou notepad...
ce sont des fichiers en texte contenant du code source windev... à mettre dans le même répertoire.
exemple :
mon_premier_programme .txt : programme vous montrant la commande INFO  ou message...
Nota sur internet si vous faites  des recherches sur GOOGLE :   WINDEV INFO vous aurez accès à l'explication de cette commande
vous pourrez ainsi rechercher ce que fait chaque instruction  des syntaxes de ce langage...
Autre exemple : windev   est un entier

On peu définir des variables, des tableaux , des tables
faire des calculs
// du commentaire
des boucle POUR TOUTES LIGNE.... FIN
                  POUR J =1 A 10....FIN

c'est un langage en français...

Le programme: charge_tirageskeno.txt  : ce programme va créer une grille à l'écran
la force de ce langage c'est que si vous faites un clic droit sur la grille  affichée vous pouvez exporter sous Excel le contenu
ou copier le contenu dans un fichier texte pour notepad...pour le traiter ailleurs ou comparer les données etc...
ce programme montre comment charger le fichier tirageskeno.csv de LACKENO  de MAVERIK
dans une table à l'écran...

Calcul_finales.txt : un troisième programme qui fait le chargement en table  du fichier tirageskeno.csv comme précédemment
mais fait en plus le calcul du nombre de finales sorties  sur tous les tirages et sur un nombre de tirages pour étude (paramètre modifiable dans le source)... et affiche une table résultat avec les finales calculées...
Nota sur chaque enregistrement de l'historique est ajouté le tirage rapproché et le nombre de N° en commun...

Evidemment tout calcul d'autres modules sont possibles, il suffit de se mettre à la programmation et d'écrire du code dans des fichiers.txt

ces 3 programmes ou fonctions sont assez simple et permettent de découvrir ce fabuleux langage...
Nota : ne pas divulguer en dehors des membre de ce site.. 
je vous laisse découvrir, 

A+
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Ven 15 Déc - 15:45

Votre premier ADDON ?...

faire un programme de calcul sur le nombre de N° pairs ou impairs du kéno

pour cela:
faite un copier/coller du programme Cacul_finales.txt
renommer cette copie en Calcul_Pairs_impairs.txt
ouvrez ce programme avec notes...

remplacer la partie calcul 
//---------------------------PHASE 3 / EXPLOITATION HISTORIQUE
//-------------------------- CALCUL DES FINALES 
... 
... jusque en bas

par ce code :


//---------------------------PHASE 3 / EXPLOITATION HISTORIQUE
//-------------------------- CALCUL DES PAIRS/IMPAIRS 
// on fait un tableau de calcul en mémoire de 2 champs nb_PAIRS NB_IMPAIRS
TableauPAIR est un tableau d'entiers
TableauEtude est un tableau d'entiers
surtout est un entier =TableOccurrence(TABLE_HISTORIQUE)
////////////////////// PHASE LE PARAMETRE DU NOMBRE DE TIRAGE DE MON ETUDE  : MODIFIABLE ///////////// 
//etude sur 7 derniers tirage par exemple
monetude est un entier =7
POUR Indice = 1 A 2
TableauPAIR[Indice] = Indice
                TableauEtude[Indice] = Indice
FIN

//pour cela on parcoure la table historique
mavaleur  = 0
wnbluh est un entier =0
bestpair est un boolean = FAUX
mafinale est un entier =0

POUR TOUTE LIGNE DE TABLE_HISTORIQUE
  wnbluh=wnbluh+1
 //recupère les 20 numéro dans les colonnes de 3 à 22
  POUR J = 1 A 20
         selon J
           cas 1: mavaleur = TABLE_HISTORIQUE.COL3..valeur
           cas 2: mavaleur = TABLE_HISTORIQUE.COL4..valeur
           cas 3: mavaleur = TABLE_HISTORIQUE.COL5..valeur
           cas 4: mavaleur = TABLE_HISTORIQUE.COL6..valeur
           cas 5: mavaleur = TABLE_HISTORIQUE.COL7..valeur
           cas 6: mavaleur = TABLE_HISTORIQUE.COL8..valeur
           cas 7: mavaleur = TABLE_HISTORIQUE.COL9..valeur
           cas 8: mavaleur = TABLE_HISTORIQUE.COL10..valeur
           cas 9: mavaleur = TABLE_HISTORIQUE.COL11..valeur
           cas 10: mavaleur = TABLE_HISTORIQUE.COL12..valeur
           cas 11: mavaleur = TABLE_HISTORIQUE.COL13..valeur
           cas 12: mavaleur = TABLE_HISTORIQUE.COL14..valeur
           cas 13: mavaleur = TABLE_HISTORIQUE.COL15..valeur
           cas 14: mavaleur = TABLE_HISTORIQUE.COL16..valeur
           cas 15: mavaleur = TABLE_HISTORIQUE.COL17..valeur
           cas 16: mavaleur = TABLE_HISTORIQUE.COL18..valeur
           cas 17: mavaleur = TABLE_HISTORIQUE.COL19..valeur
           cas 18: mavaleur = TABLE_HISTORIQUE.COL20..valeur
           cas 19: mavaleur = TABLE_HISTORIQUE.COL21..valeur
           cas 20: mavaleur = TABLE_HISTORIQUE.COL22..valeur
         FIN
          // test si pair 
          bestpair =EstPair( mavaleur)
          si bestpair = VRAI alors
              SI  wnbluh <= surtout alors
              TableauPAIR[1] =  TableauPAIR[1] + 1
               FIN
               SI  wnbluh <= monetude alors
TableauEtude[1] = TableauEtude[1] + 1
              FIN
           sinon
              //impairs
              SI  wnbluh <= surtout alors
              TableauPAIR[2] =  TableauPAIR[2] + 1
               FIN
               SI  wnbluh <= monetude alors
TableauEtude[2] = TableauEtude[2] + 1
               FIN   
          FIN
         //fin pour J
         FIN
FIN

/// affichage des resultat dans une table a l'écran avec 2 lignes
// 1ere ligne les finales sur monetude
// 2 e ligne sur l'ensemble des tirages (surtout)
TABLE_RESULTATPAIR est un Champ
TABLE_RESULTATPAIR <- ChampCrée("TABLE_RESULTATPAIR", typTable,10, 400, 1200, 100, Vrai)
TABLE_RESULTATPAIR..Ancrage = ancreLargeur + ancreHauteur 
xxcol1 est un Champ <- ChampCrée("TABLE_RESULTATPAIR.COL1", typColonne)
xxcol1..TypeSaisie = typSaisieTexte
xxcol2 est un Champ <- ChampCrée("TABLE_RESULTATPAIR.COL2", typColonne)
xxcol2..TypeSaisie = typSaisieTexte
xxcol3 est un Champ <- ChampCrée("TABLE_RESULTATPAIR.COL3", typColonne)
xxcol3..TypeSaisie = typSaisieTexte

TableAjouteLigne(TABLE_RESULTATPAIR, "NB PAIRS","NB IMPAIRS","TIRAGES")
TableAjouteLigne(TABLE_RESULTATPAIR,TableauEtude[1],TableauEtude[2]," Sur "+monetude+" Tirages de Mon Etude")
TableAjouteLigne(TABLE_RESULTATPAIR,TableauPAIR[1],TableauPAIR[2]," Sur "+surtout+ " Tirages" )


Faites enregistrer le fichier sous Calcul_Pairs_impairs.txt dans le répertoire

Vous pouvez l' Exécuter...

A bientôt...
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Ven 15 Déc - 16:16

Bonsoir Terminator .
.

Tu devrais ouvrir une section Apprentissage.........Windev.
Après tout ,c'est compatible avec les jeux de loterie ou autre besoins quotidien  Wink.
Cette section peut avoir sa place sur le forum  Very Happy.
En plus Un pro pour Professeur   Cool.
Cela pourrait devenir un valeur ajoutée au forum ;
A cogiter....... Wink.

J'ai mis ton code Gentiment partagé dans la fenêtre Appropriée . Laughing
J'ai laissé les commentaires  Wink.

Code:
//---------------------------PHASE 3 / EXPLOITATION HISTORIQUE
//-------------------------- CALCUL DES PAIRS/IMPAIRS 
// on fait un tableau de calcul en mémoire de 2 champs nb_PAIRS NB_IMPAIRS
TableauPAIR est un tableau <agrandissement=1> d'entiers
TableauEtude est un tableau <agrandissement=1> d'entiers
surtout est un entier =TableOccurrence(TABLE_HISTORIQUE)
////////////////////// PHASE LE PARAMETRE DU NOMBRE DE TIRAGE DE MON ETUDE  : MODIFIABLE ///////////// 
//etude sur 7 derniers tirage par exemple
monetude est un entier =7
POUR Indice = 1 A 2
TableauPAIR[Indice] = Indice
                TableauEtude[Indice] = Indice
FIN

//pour cela on parcoure la table historique
mavaleur  = 0
wnbluh est un entier =0
bestpair est un boolean = FAUX
mafinale est un entier =0

POUR TOUTE LIGNE DE TABLE_HISTORIQUE
  wnbluh=wnbluh+1
 //recupère les 20 numéro dans les colonnes de 3 à 22
  POUR J = 1 A 20
         selon J
           cas 1: mavaleur = TABLE_HISTORIQUE.COL3..valeur
           cas 2: mavaleur = TABLE_HISTORIQUE.COL4..valeur
           cas 3: mavaleur = TABLE_HISTORIQUE.COL5..valeur
           cas 4: mavaleur = TABLE_HISTORIQUE.COL6..valeur
           cas 5: mavaleur = TABLE_HISTORIQUE.COL7..valeur
           cas 6: mavaleur = TABLE_HISTORIQUE.COL8..valeur
           cas 7: mavaleur = TABLE_HISTORIQUE.COL9..valeur
           cas 8: mavaleur = TABLE_HISTORIQUE.COL10..valeur
           cas 9: mavaleur = TABLE_HISTORIQUE.COL11..valeur
           cas 10: mavaleur = TABLE_HISTORIQUE.COL12..valeur
           cas 11: mavaleur = TABLE_HISTORIQUE.COL13..valeur
           cas 12: mavaleur = TABLE_HISTORIQUE.COL14..valeur
           cas 13: mavaleur = TABLE_HISTORIQUE.COL15..valeur
           cas 14: mavaleur = TABLE_HISTORIQUE.COL16..valeur
           cas 15: mavaleur = TABLE_HISTORIQUE.COL17..valeur
           cas 16: mavaleur = TABLE_HISTORIQUE.COL18..valeur
           cas 17: mavaleur = TABLE_HISTORIQUE.COL19..valeur
           cas 18: mavaleur = TABLE_HISTORIQUE.COL20..valeur
           cas 19: mavaleur = TABLE_HISTORIQUE.COL21..valeur
           cas 20: mavaleur = TABLE_HISTORIQUE.COL22..valeur
         FIN
          // test si pair 
          bestpair =EstPair( mavaleur)
          si bestpair = VRAI alors
              SI  wnbluh <= surtout alors
              TableauPAIR[1] =  TableauPAIR[1] + 1
               FIN
               SI  wnbluh <= monetude alors
TableauEtude[1] = TableauEtude[1] + 1
              FIN
           sinon
              //impairs
              SI  wnbluh <= surtout alors
              TableauPAIR[2] =  TableauPAIR[2] + 1
               FIN
               SI  wnbluh <= monetude alors
TableauEtude[2] = TableauEtude[2] + 1
               FIN   
          FIN
         //fin pour J
         FIN
FIN

/// affichage des resultat dans une table a l'écran avec 2 lignes
// 1ere ligne les finales sur monetude
// 2 e ligne sur l'ensemble des tirages (surtout)
TABLE_RESULTATPAIR est un Champ
TABLE_RESULTATPAIR <- ChampCrée("TABLE_RESULTATPAIR", typTable,10, 400, 1200, 100, Vrai)
TABLE_RESULTATPAIR..Ancrage = ancreLargeur + ancreHauteur 
xxcol1 est un Champ <- ChampCrée("TABLE_RESULTATPAIR.COL1", typColonne)
xxcol1..TypeSaisie = typSaisieTexte[size=16][/size]
xxcol2 est un Champ <- ChampCrée("TABLE_RESULTATPAIR.COL2", typColonne)
xxcol2..TypeSaisie = typSaisieTexte[size=16][/size]
xxcol3 est un Champ <- ChampCrée("TABLE_RESULTATPAIR.COL3", typColonne)
xxcol3..TypeSaisie = typSaisieTexte

TableAjouteLigne(TABLE_RESULTATPAIR, "NB PAIRS","NB IMPAIRS","TIRAGES")
TableAjouteLigne(TABLE_RESULTATPAIR,TableauEtude[1],TableauEtude[2]," Sur "+monetude+" Tirages de Mon Etude")
TableAjouteLigne(TABLE_RESULTATPAIR,TableauPAIR[1],TableauPAIR[2]," Sur "+surtout+ " Tirages" )
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Ven 15 Déc - 17:54

Merci berly , on fait comment une fenêtre de ce type sur ce site ?
sinon je ne suis pas un 'pro' , mais j'essaye...
sinon  il me faudrait des idées  sur le comment Prédire quelques N° au KENO à partir des tirages  ... 
pour faire un module à forte valeur ajoutée...
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Ven 15 Déc - 18:17

Ah je croyais que c'était ton métier .
Bref ça n'a aucune importance , cela n'enlève rien a tes grandes qualités  Wink.

Pour la fenêtre ,dans l'interface de message,Il faut parcourir les contrôles,puis cliquer sur Le bouton Code.
La fenêtre apparaît......



En principe On ouvre le crochet 

Tu copie,colle le code .

On ferme le crochet.

Certaines choses ne doivent pas fonctionner ,mais ça tu verras par toi même.
J'ai été obligé de supprimer Les [ sizes] qui apparaissaient ......

Des idées j'en ai ....... On verra si j'ai le temps  Wink.

A+
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Ven 15 Déc - 18:32

Merci Berly...

sinon un addon supplémentaire :
à la fin de votre code avec ces 3 lignes vous pouvez exporter le contenu d'une table
vers un fichier CSV  ( pour excel )
il vous suffit de remplacer TABLE_MATABLE par le nom de la table à Exporter dans votre programme , par exemple dans calculs pairs impairs la table finale se nome
TABLE_RESULTAT  à mettre à la place de TABLE_MATABLE
et si vous voulez mettre le fichier.csv dans un répertoire précis :
il vous suffit de remplacer frepexe()+"\nomdu.csv"
par  "c:\mon_répertoire\mon_fichier.csv"
Nota: frepexe() est le répertoire courant ou se trouve le programme...

Code:
sText est une chaîne
sText = TableVersTexte(TABLE_MATABLE, taSansTitre, " ")
fSauveTexte(frepexe()+"\Export.csv", sText)

vous pouvez même lancer automatiquement excel si vous avez associé sur votre machine les .csv avec Excel...
il vous suffit d'ajouter à la fin
LanceAppliAssociée("c:\mon_répertoire\mon_fichier.csv")


Dernière édition par TERMINATORLOTO le Ven 15 Déc - 19:55, édité 3 fois
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Ven 15 Déc - 18:34

Laughing Laughing Laughing .  Wink
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Ven 15 Déc - 18:43

En fait ,avec Windev ça fonctionne comme en Python .

Module MonFichier.Py
Chaque Module écrit est indépendant ...... c'est hyper flexible .
Marre des IDE ,Vive l'écriture Libre,éditeur de texte,Compilation en ligne de commande....Et basta  Laughing.

Appel du fichier,Fonctions,Base de donnée .csv ,dans une autre procédure (Fichier). Cool
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Sam 16 Déc - 8:03

petite précision  dans les 2 programme de calculs :
:
wnbluh = c'est la lecture des tirages  en cours :  de 1 à tous les tirages
surtout = contient le nombre total de tirages 
monetude =7     cela signifie une étude sur les 7 premiers tirages...
vous pouvez changer sa valeur...

****test sur les 7 premiers tirages
        SI  wnbluh <= monetude alors
TableauEtude[mafinale] = TableauEtude[mafinale] + 1
        FIN


si vous voulez faire une étude sur les 7 derniers tirages
il faut remplacer le test par :

        SI  wnbluh  > (surtout -  monetude  ) alors
     TableauEtude[mafinale] = TableauEtude[mafinale] + 1
        FIN

A+
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Sam 16 Déc - 12:00

Bonjour 
un petit exemple montrant le dernier tirage en haut
et les numéros sortis dans les  6 tirages précédents
a la vue de cet exemple tout laisse a penser
que le tirage antérieur avec 8 communs et le 6e tirage antérieur avec 7 communs sont
les plus prolifiques...

[Vous devez être inscrit et connecté pour voir ce lien]

Mais comment le vérifier sur tous les tirages

(j'ai modifié calcul_finales  dans ma programmation.zip )
pour faire ce rapprochement sur tous les tirages...
 [Vous devez être inscrit et connecté pour voir ce lien]

voila  a quoi peut servir la programmation
il suffit de tester avec d'autres valeurs par exemple -3 et -4
pour voir que c'est meilleurs sur l'ensemble des tirages
 
 nbaa3 =(  nbab -6)     mettre -4 à la place de -6
 nbaa =(  nbab -1)       mettre -3  à la place de -1

A+....
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Sam 16 Déc - 13:11

Comment ajouter un diagnostic aux calcul finales ?
par exemple savoir si dans son étude on est en avance ou en retard / totalité des tirages...
on va le symboliser par UN + pour ceux qui sont en Avance 
et par un - pour les finales en retard...
exemple la finale 4 est en retard
[Vous devez être inscrit et connecté pour voir ce lien]

voici le code a ajouter  avant l'export...
Code:
//-------------------------------------------------------------------------------
//--- FINALES :  ajout + en avance  ou - en retard aux finales
wx1 est une chaine =""
wx2 est une chaine =""
wx3 est une chaine =""
wx4 est une chaine =""
wx5 est une chaine =""
wx6 est une chaine =""
wx7 est une chaine =""
wx8 est une chaine =""
wx9 est une chaine =""
wx10 est une chaine=""
si ( TableauEtude[1]/ monetude) < (TableauFinale[1]/surtout) ALORS
  WX1="-"
sinon
  WX1="+"
FIN
si ( TableauEtude[2]/ monetude) < (TableauFinale[2]/surtout) ALORS
  WX2="-"
sinon
  WX2="+"
FIN
si ( TableauEtude[3]/ monetude) < (TableauFinale[3]/surtout) ALORS
  WX3="-"
sinon
  WX3="+"
FIN
si ( TableauEtude[4]/ monetude) < (TableauFinale[4]/surtout) ALORS
  WX4="-"
sinon
  WX4="+"
FIN
si ( TableauEtude[5]/ monetude) < (TableauFinale[5]/surtout) ALORS
  WX5="-"
sinon
  WX5="+"
FIN
si ( TableauEtude[6]/ monetude) < (TableauFinale[6]/surtout) ALORS
  WX6="-"
sinon
  WX6="+"
FIN
si ( TableauEtude[7]/ monetude) < (TableauFinale[7]/surtout) ALORS
  WX7="-"
sinon
  WX7="+"
FIN
si ( TableauEtude[8]/ monetude) < (TableauFinale[8]/surtout) ALORS
  WX8="-"
sinon
  WX8="+"
FIN
si ( TableauEtude[9]/ monetude) < (TableauFinale[9]/surtout) ALORS
  WX9="-"
sinon
  WX9="+"
FIN
si ( TableauEtude[10]/ monetude) < (TableauFinale[10]/surtout) ALORS
  WX10="-"
sinon
  WX10="+"
FIN
TableAjouteLigne(TABLE_RESULTAT,WX1,WX2,WX3,WX4,WX5,WX6,WX7,WX8,WX9,WX10 )
//----------------------------------------------------------------------------

Bon toutes ces modifications elles sont misent à jour dans les programmes du zip...
de plus pour le paramètre d' Etude sur x derniers tirages, j'ai ajouté une saisie au début des programmes..
par la commande saisie(...)
Bon Développements ., Bon weekend..
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Sam 16 Déc - 17:05

Terminator a précisé :

ces 3 programmes ou fonctions sont assez simple et permettent de découvrir ce fabuleux langage...
Nota : ne pas divulguer en dehors des membre de ce site.. 
je vous laisse découvrir, 

A+


Info  Exclamation ce message peut être consulté par tous .(Hors connexion)
Pas besoin d'être inscrit sur le forum .
Le programme peut être également téléchargé.
LacKeno lui est protégé.


A voir si cela doit rester ainsi.... Maverik 
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par Maverik le Sam 16 Déc - 19:30

C'est fait Berly .
avatar
Maverik
Admin
Admin

Messages : 4948
Date d'inscription : 16/02/2016
Age : 64
Localisation : Martigues

http://faites-du-jeu.forumactif.org

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Sam 16 Déc - 21:12

Merci Pour Terminator,Maverik  Wink.
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Sam 16 Déc - 21:22

Bonsoir Terminator.

Calculs sur colonne Fichier.csv: une colonne par numéro sortis.

Combien de fois sur l'ensemble des tirages ,les valeurs présentes dans les colonnes 4,7,8
sont ressorties au tirage suivant  Question
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Dim 17 Déc - 9:12

Bonjour Berly,

peu tu valider ta demande ?

Tu souhaite que je comptabilise  les Re-sortis (ou sortis aux tirages suivants uniquement )
mais pourquoi 4 7 8 ?   uniquement pour ces 3 numéros ou sur tous les numéros de 1 à 70 ?

méthode de calcul : exemple un numéro qui sort au total 6 fois
mais en 2 séries , cela donnerais 4 ?  
 exemple:
Quand à la comptabilisation si sort 2 fois de suite = +1
                                          si sort 3 fois de suite = +2
                                           si sort 4 fois de suite = +3
                                      ... c'est ça ?
 
et si plus loin ressort 2 fois de suite                       = +1  ?

donc au total                                                      = sortis 4 fois  de suite pour 6 sortis

                                                                           ou  bien  2 fois de suite ?   

                     1     2   3   4   5   6   7   8   9   10   11 ....70     Numéros de 1 à 70
 nb_suivant    14    8   6   4   8     
....
? = nb de sorties au tirage suivant
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Dim 17 Déc - 10:32

les valeurs présentes dans les colonnes 4,7,8
sont ressorties au tirage suivant  

Colonne ou range 1,
Premier N° se trouve dans la colonne 1,

Ex le 11 se trouve dans la colonne 4,le 15 se trouve dans la colonne 7,le 20 se trouve dans la colonne 8.

donc ,il s'agit de lire les valeurs qui se trouvent dans ces colonnes respectives,de stocker les valeurs dans une variable  tableau,et vérifier leur ressortie sur le tirage suivant .
Ce qui en soit demande une lecture et vérification du résultat sur l'ensemble des tirages.
Mais pour moi si tu arrives a obtenir le résultat ,selon les résultat obtenus,ce sera mon
 dernier test .....

A+
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Dim 17 Déc - 10:51

Désolé Berly c'est pas clair pour moi....
si le 1 est en colonne 1
Pourquoi le 11 se trouverait  dans la colonne 4 ?
car je parcoure tous les enregistrements ou tirages dans l'ordre des tirages

et je compare les N° de chaque tirage avec les n° du tirage suivant
si même n° alors +1 dans sa comptabilisation de nb de sortis_suivant pour  ce n°...

j'ai modifié le zip  (revu tous les programmes , car dans les exports.csv  les blancs faisaient des colonnes en + )

J'ai écrit vite fait calcul_suivant.txt  ( calculs à vérifier)
une ligne avec une entête sur les 70 N°
2e ligne avec leurs nb de sortis sur l'ensemble des tirages
3e ligne avec le nb de fois ou ils sont sortis au tirage suivant
et exporte le tout en export_fichier_suivant.csv
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Dim 17 Déc - 11:12

Pourquoi tu te bornes a prendre le N°1 en colonne 1.

3 positions a vérifier sur l'ensemble des tirages ,pour ne pas dire plus,cela ne servirait a rien.

Car les valeurs composantes des meilleures combinaisons ,se trouvent dans une position dans le tirage ,puis dans une autre au tirage suivant.

si cette position ne se renouvelle pas un certain nombre de fois sur l'ensemble des tirages .

cela ne vaut pas le coup d'aller plus loin......
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Dim 17 Déc - 11:47

si je comprend bien tu veux que je contrôle uniquement les N° pris en position 4  7 8
des tirages avec sortis sur le tirage précédent : question mais aussi en position 4 7 8 ?


c'est a dire
exemple le 11 --> 0 sur ces 3 tirages sur position 4 7 8
             le  18 --> 2 fois ces 3 tirages  sur position 4 7 8 
             le 22   ---> 0 fois   sur 4 7 8   ( ou une fois ? 
                                 X         x   x   
tirage        01 02  03  11  15  18  22  23  24  30  37  38  45  50  56  59  61  63  64  68
                04  05 10  15  17  18  21  22  25  27  31  35  41  46  47  49  50  53  56  66
                02  05 06  10  15  18  19  20  26  32  33  36  39  48  49  54  56  62  63  68
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par BERLY le Dim 17 Déc - 11:55

tirage        01 02  03  11  15  18  22  23  24  30  37  38  45  50  56  59  61  63  64  68
                04  05 10  15  17  18  21  22  25  27  31  35  41  46  47  49  50  53  56  66
Vérification
                02  05 06  10  15  18  19  20  26  32  33  36  39  48  49  54  56  62  63  68
Sortis ou pas


Ainsi de suite.....


C'est ça ......ce sera bien suffisant pour l'instant


Déja on peut voir que le N° en position 7 est sortis 3 fois ...... a voir pour le reste...
avatar
BERLY
Héro
Héro

Messages : 2581
Date d'inscription : 18/02/2016
Age : 53
Localisation : Rodez

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Dim 17 Déc - 13:01

bon j'ai modifié le zip

Dans le programme je demande 3 positions a analyser...
Retourposition1  par defaut = 4
Retourposition2  par defaut = 7
Retourposition3  par defaut = 8
donc ces 3 valeurs sont modifiables en saisie...

Dans le code que tu peu modifier :
4 tableaux spécifiques sont ajoutés  pour ces sortis 
 // en position 4 7 8  berly
//sur l'ensemble des tirages nd de sorti
BBS est un tableau d'entiers
// sur l' Etude des derniers tirages (7  derniers tirages par défaut modifiable en saisie)
BBE est un tableau d'entiers

//------------------selon tes 3 positions
//nb de sortis sur étude et suivant si en position spécifiques saisie
// sur l'ensemble des tirages
BES est un tableau d'entiers
// sur les  derniers tirages de l'Etude (7 par défaut mais modifiable en saisie )
BEE est un tableau d'entiers

 

Et dans le code
les  tests sont de même principe :
   // analyse les N° de l'enregistrement  courant  avec les N° à ces 3 positions  (ne pas toucher)
   SI J = Retourposition1 OU J= Retourposition2  OU J = Retourposition3 ALORS
et contrôle sur le tirage suivant si en même position on a le même N°.                   
 
--- mettre ainsi sur les 2 tests sur l'ensemble et sur l'étude
//    SI K = Retourposition1 OU K= Retourposition2  OU K = Retourposition3 ALORS
                             BEE[mavaleur2] = BEE[mavaleur2] + 1
// FIN

 //  SI K = Retourposition1 OU K= Retourposition2  OU K = Retourposition3 ALORS
                            BBE[mavaleur2] = BBE[mavaleur2] + 1
 //FIN
        
si quelque soit la position dans le suivant  sinon si on veut à la m^me position remettre le test (enlever les //)...


A toi de jouer Berly tu a maintenant toutes les ressources pour pouvoir faire ce que tu souhaite
 juste creuser un peu le code et le modifier à ta convenance...
[Vous devez être inscrit et connecté pour voir ce lien]
voila ce que cela donne sur une analyse des 3 derniers tirages
on voit le 18 et le 15 avec sorti 2 fois dans le suivant
le 22 sorti  1 fois au suivant
et 11 19  21  mais sorti 0 fois au suivant...
[Vous devez être inscrit et connecté pour voir ce lien]
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Mer 20 Déc - 21:18

Bonsoir,
Dans le lien vers maprogrammation.zip le module de chargement de mise à jour des tirages avec tirageskeno.csv  a été modifié dans les 3 modules.  (bug corrigé)...

Dans le module Calcul_Sorti_suivant.txt:
Dans la table des résultats , une ligne avec les numéros en prévisions à été ajoutée
et avec ces numéros de prédictions apparaît une nouvelle  table avec un système combinatoire de quelques combinaisons à l'écran.
Vous avez ainsi  un exemple de tous les modules nécessaires  pour pouvoir écrire vos propres codes ... 
Bon développement, et  bonnes  et heureuses fêtes de fin d'année à tous...


Dernière édition par TERMINATORLOTO le Ven 22 Déc - 10:40, édité 1 fois
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par Adouli le Jeu 21 Déc - 11:11

Merci Terminatorloto pour ce développement What a Face
Bonne et heureuse fin d'année à toi également   santa
avatar
Adouli
Héro
Héro

Messages : 4281
Date d'inscription : 17/02/2016
Age : 49
Localisation : La Chapelle en serval

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par TERMINATORLOTO le Ven 22 Déc - 8:26

merci Adouli, Bonne et heureuse fin d'année à toi également   

(nota: La dernière version de calcul_suivant avec quelques mise en forme... en date du 22/12/2017)
A+
avatar
TERMINATORLOTO
Héro
Héro

Messages : 2105
Date d'inscription : 18/03/2016

Revenir en haut Aller en bas

Re: Voulez vous développer vous même vos propres codes ?

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Poster un nouveau sujet   Répondre au sujet
 
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum